信息资讯综合思念体

composer 依赖错误会下载较高版本的组件

composer国内源有bug 会导致部分依赖包下载错误。

比如 "jenssegers/mongodb": "3.1.*" 组件支持 laravel ^5.1 相当于支持 大于 5.1的各个版本。可是laravel自己可不支持各个版本。导致主框架用的是5.1 可是被下载了5.4的组件,项目无法运行。

如果出现组件下载后报bug的问题,可切换到国外源再进行安装。

感觉国外源太慢,而且不会翻墙的,请将国内源:

{"type": "composer", "url": "https://packagist.phpcomposer.com"}


改为:

{"type": "composer", "url": "http://pkg.overtrue.me"}


并执行命令:

> composer config --global secure-http false



«   2021年9月   »
12345
6789101112
13141516171819
20212223242526
27282930
网站分类
搜索
最新留言
文章归档
网站收藏
友情链接
  • RainbowSoft Studio Z-Blog
  • 订阅本站的 RSS 2.0 新闻聚合

Powered By Z-BlogPHP 1.5.1 Zero Theme By 爱墙纸

百度资讯综合思念体对有机生命接触用人形终端界面 那就是
晋ICP备15000230号-1