信息资讯综合思念体

【Kafka】在java11中使用kafka流行版本0.11.0.3中缺少javaEE相关组件的问题

用php在接入Kafka的时候,遇到了些老大难的问题。


问题一:

nmred/kafka-php@0.2.* 包不支持 0.11 以上的kafka版本。


解决方案:给php安装rdkafka的php扩展 php-rdkafka。(其实360也有一个包,但是。。)


问题二:

当前的流行java版本是11,剔除了javaEE的组件。出现了 java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter 错误。


解决方案:其实网上已经蛮多了。手动加呗。

下载如下4个包:

https://repo1.maven.org/maven2/com/sun/xml/bind/jaxb-core/2.3.0.1/jaxb-core-2.3.0.1.jar

https://repo1.maven.org/maven2/com/sun/xml/bind/jaxb-impl/2.3.2/jaxb-impl-2.3.2.jar

https://repo1.maven.org/maven2/javax/activation/javax.activation-api/1.2.0/javax.activation-api-1.2.0.jar

https://repo1.maven.org/maven2/javax/xml/bind/jaxb-api/2.3.1/jaxb-api-2.3.1.jar

复制到 kafka/lib 文件夹内。


得以启动~

«   2020年11月   »
1
2345678
9101112131415
16171819202122
23242526272829
30
网站分类
搜索
最新留言
文章归档
网站收藏
友情链接
  • RainbowSoft Studio Z-Blog
  • 订阅本站的 RSS 2.0 新闻聚合

Powered By Z-BlogPHP 1.5.1 Zero Theme By 爱墙纸

百度资讯综合思念体对有机生命接触用人形终端界面 那就是
晋ICP备15000230号-1